The Parametric Bolt Edit window

  • Add Bolt Point to Point :

Also see :

Quick Notes

Warning :

  • If your startup code specifies imperial Units("...") , make entries to distance fields on this window in decimal inches, not fractions. Also, do not use hyphens ( - ). If you enter a fraction using integers, Python truncates the results of the division operation to an integer (examples: 1/8 = 0 ; 5/4 = 1 ). If you enter fractions with decimal points, Python calculates the precise decimal value (examples: 1.0/8.0 = .125 ; 5.0/4.0 = 1.25 ). If you enter a hyphen, Python interprets the hyphen as a minus sign (examples: 1-2 = -1 ; 3-2 = 1 ). See numbers (floating point numbers and integers). Tip : To enter a dimension string and convert it to a floating point distance that is properly factored based on the startup code Units("...") , you can use the dim("...") function.

Example of Add Bolt Point to Point :

# Adds a nut and washer to a threaded round bar. 
from param import ClearSelection 
from member import Member, MemberLocate 
from bolt_add import * 
ClearSelection() 
mem = MemberLocate("Select a round bar member") 
# bolt add begin 
bolt1 = Bolt() 
bolt1.Member = mem 
bolt1.HeadPoint = mem.LeftEnd.Location + mem.TranslateToGlobal(1.5,0,0) 
bolt1.NutPoint = mem.LeftEnd.Location + mem.TranslateToGlobal(0.5,0,0) 
bolt1.Diameter = 1 
bolt1.Length = 2.15 
bolt1.Grip = 1.15 
bolt1.PrimaryNutType = "Heavy hex" 
bolt1.PrimaryNutGrade = "A563" 
bolt1.BoltType = "A325N" 
bolt1.IsFieldBolt = "Shop" 
bolt1.IsTensionControl = "No" 
bolt1.Boltless = "Yes" 
bolt1.Finish = "Black" 
bolt1.HillsideWasherAngle = 0 
bolt1.PrimaryNutWasher.TypeDescription = "Hardened" 
bolt1.PrimaryNutWasher.GradeDescription = "F436" 
bolt1.PrimaryNutWasher.Quantity = 1 
bolt1.PrimaryNutWasher.Thickness = 0.15625 
bolt1.PrimaryNutWasher.Width = 1.5 
bolt1.PrimaryNutWasher.Rotation = 0 
bolt1.Direction = "Out" 
bolt1.AddPointToPoint() 
# bolt add end 
ClearSelection()
   
A bolt and washer generated using the code shown above.

The " Units " of measure in this script are Units("feet") .

For this script to work properly, the threaded round bar must be Centered .

See " Member " for an explanation of the lines of code that read mem = MemberLocate("Select a round bar member") and bolt1.Member = mem .

See " Head point " and " Nut point " for an explanation of the lines of code that read bolt1.HeadPoint = mem.LeftEnd.Location + mem.TranslateToGlobal(1.5,0,0) and bolt1.NutPoint = mem.LeftEnd.Location + mem.TranslateToGlobal(.5,0,0) .

The line of code that reads bolt1.AddPointToPoint() executes the Add Bolt Point to Point operation.


------ General settings ------

Class ( obj .IsFieldBolt or obj.bolt_class ): "Field" or "Shop" . The choice you make here results in the entry of a string ( "Field" or "Shop" ) to the parametric code.

' Field bolts ' and ' Shop bolts ' can be displayed in different colors . Setup for this is done on the Member, Material, Bolt and Weld Colors window.

Example: Selecting Field adds a line to the parametric code that reads obj.IsFieldBolt = "Field" (where obj is the " Object name ").

Flip direction ( obj .Direction or obj.direction ): ( "In" ) or ( "Out" ).The choice you make here results in the entry of a string ( "In" or "Out" ) to the parametric code. In and out work much like toe in and toe out on a channel beam.

If this box is checked ( ), a line is added to the parametric code that reads: obj.Direction = "In" (where obj is the " Object name "). "In" points the bolt shank down (head up) in a plan view. It points the shank toward the right if the hole is drilled horizontally through a material that is shown as vertical in a plan view. It points the shank toward you if you are facing the near side of a member in an elevation view.

If this box is not checked ( ), a line is added to the parametric code that reads: obj.direction = "Out" (where obj is the " Object name ").

Finish ( obj .SurfaceFinish or obj.finish ): "Black" or "Mechanically galvanized" or "Hot dipped galvanized" . The choice you make here results in the entry of a string ( "Black" or "Mechanically galvanized" or "Hot dipped galvanized" ) to the parametric code.

Example: Selecting Black adds a line to the parametric code that reads: obj.DurfaceFinish = "Black" (where obj is the " Object name ").

Diameter ( obj .Diameter or obj.diameter ): The diameter of the shank of the bolt. You can either type in a diameter, or you can select a bolt diameter from the combo box ( ). The diameters that are listed in the combo box come from Home > Project Settings > Job > Bolt Settings > the " Available bolt diameters " list. The choice you make here results in the entry of a floating point number (in mm or inches -- see " Units ") to the parametric code.

diameter

Example: Suppose that Units("feet") are the startup code units and you select '3/4 inch' from this menu. The result is a line of parametric code that reads: obj.Diameter = 0.75 (where obj is the " Object name ").


------ Bolt settings ------

Bolt ( obj .Boltless or obj.boltless ): ( "No" ) or ( "Yes" ). The choice you make here results in the entry of a string ( "No" or "Yes" ) to the parametric code.

Bolt Bolt

If this box is checked ( ), the bolt is generated along with the nuts and washers. The result is a line of parametric code that reads: obj.Boltless = "Yes" (where obj is the " Object name ").

If the box is not checked ( ) and the boxes for " Nut " and " Washer " are checked, you get the nuts and washers only. The result is a line of parametric code that reads: obj.Boltless = "No" .

Bolt type ( obj .BoltType or obj.bolt_type ): A325NG or A325S or A325SX , etc. This is the bolt type of the bolt whose settings are defined on this window. The choice you make here results in the entry of a string to the parametric code.

Setup: If the bolt type that you want does not appear as a selectable option ( ), you may add it in to the menu for this field using the Bolt Specifications .

Example: Selecting ' A325N ' as the " Bolt type " results in a line in the parametric code that reads: obj.BoltType = "A325N" (where obj is the " Object name ").

Bolt length ( obj .Length or obj.length ): The distance (a floating point number in mm or inches -- see " Units ") from the inside of the bolt head to the end of the bolt shank. Head thickness is not incluced in the calculation of bolt length because head thickness may vary among bolt manufacturers.

length

Example: You enter 2.0 as the " Bolt length ." The result is a line of parametric code that reads: obj.Length = 2.0 (where obj is the " Object name ").

Bolt grip ( obj .Grip or obj.grip ): The distance (a floating point number in mm or inches -- see " Units ") between the inside of the bolt head and inside of the nut. If there are washers on the bolt, the bolt grip is measured from the inside of the washers.

g = grip

Example: You enter 0.5 as the " Bolt length ." The result is a line of parametric code that reads: obj.Grip = 0.5 (where obj is the " Object name ").

Tension control ( obj .IsTensionControl or obj.tc ): ( "Yes" ) or ( "No" ). The choice you make here results in the entry of a string ( "Yes" or "No" ) to the parametric code.

Tension Control Tension Control
Only TC field bolts are displayed with the splined end. TC shop bolts look the same as non-TC bolts.

If this box is checked ( ), the bolt is designated as a TC bolt. A TC bolt is a bolt with a splined end extending beyond the threaded portion of the bolt. The bolt is installed using a special wrench that removes the splined end when the bolt is tightened to the proper tension. The result is a line of parametric code that reads: obj.IsTensionControl = "Yes" (where obj is the " Object name ").

If the box is not checked ( ), the bolt is not a TC bolt. The result is a line of parametric code that reads: obj.IsTensionControl = "No" .


------ Nut settings ------

Nut: or .

Nut Nut

Primary nut ( obj .PrimaryNutType or obj.primary_nut ): "None" or "Heavy hex" or "Heavy square" or "Jam" . The primary nut is the nut that is closest to the material that is being fastened. The choice you make here results in the entry of a string (' None ' or ' Heavy square ' or ' Heavy hex ' or ' Jam ') to the parametric code.

"Heavy hex" "Heavy square" "Jam"

"None" generates the bolt without a nut. The result is a line of parametric code that reads: obj.PrimaryNutType = "None" (where obj is the " Object name ").

"Heavy square" generates a hexagonal-shaped primary nut. The result is a line of parametric code that reads obj.PrimaryNutType = "Heavy square" .

"Heavy hex" generates a square-shaped primary nut. The result is a line of parametric code that reads: obj.primary_nut = "Heavy hex" .

"Jam" generates a jam nut. The result is a line of parametric code that reads: obj.PrimaryNutType = "Jam" .

Primary nut grade ( obj .PrimaryNutGrade or obj.primary_nut_grade ): Any grade entered to the " Nuts " tab at Home > Project Settings > Job > Nut and Washer Schedule for the selected type (' Heavy square ' or ' Heavy hex ' or ' Jam ') can be selected on the list box ( ) for this field. The choice you make here results in the entry of a string to the parametric code.

Example: You select A563 as the " Primary nut grade ." The result is a line of parametric code that reads: obj.PrimaryNutGrade = "A563" (where obj is the " Object name ").

Secondary nut ( obj .SecondaryNutType or obj.secondary_nut ): "None" or "Heavy hex" or "Heavy square" or "Jam" . The secondary nut is the nut that is closest to the end of the bolt. The choice you make here results in the entry of a string ( 'None' or 'Heavy square' or 'Heavy hex' or 'Jam' ) to the parametric code.

"Heavy hex" "Heavy square" "Jam"

"None" prevents a secondary nut from being generated.

"Heavy hex" generates a hexagonal-shaped secondary nut.

"Heavy square" generates a square-shaped secondary nut.

"Jam" generates a jam nut.

Secondary nut grade ( obj .SecondaryNutGrade or obj.secondary_nut_grade ): Any grade entered to the " Nuts " tab at Home > Project Settings > Job > Nut and Washer Schedule for the selected type (' Heavy square ' or ' Heavy hex ' or ' Jam ') can be selected on the list box ( ) for this field. The choice you make here results in the entry of a string to the parametric code.

Example: You select A563 as the " Secondary nut grade ." The result is a line of parametric code that reads: obj.SecondaryNutGrade = "A563" (where obj is the " Object name ").


------ Washer settings ------

Washer: or .

Washer Washer
|| Under Nut || Under Head ||
|| Primary || Secondary || Tertiary ||
The "primary" position is closest to the steel being fastened. The "secondary" position is the next closest. The "tertiary" washer is closest to the end of the bolt (its nut or head).

Type ( obj .PrimaryNutWasher.TypeDescription or obj .SecondaryNutWasher.TypeDescription or obj .TertiaryNutWasher.TypeDescription or obj .PrimaryHeadWasher.TypeDescription or obj .SecondaryHeadWasher.TypeDescription or obj .TertiaryHeadWasher.TypeDescription ): "None" or "Hardened" or "Square plate" or "Round plate" or "Flat" or "Bevel" or "Load" or "Hillside" .

Hardened (HD) Square plate (PL) Round plate (RPL) Flat (FL) Bevel (BVL) Load (LD) Hillside (HLS)

Example: You select Hardened as the " Type " under the " Primary " column of the " Under Head " tab. The result is a line of parametric code that reads: obj.PrimaryHeadWasher.TypeDescription = "None" (where obj is the " Object name ").

Grade ( obj .PrimaryNutWasher.GradeDescription or obj .SecondaryNutWasher.GradeDescription or obj .TertiaryNutWasher.GradeDescription or obj .PrimaryHeadWasher.GradeDescription or obj .SecondaryHeadWasher.GradeDescription or obj .TertiaryHeadWasher.GradeDescription ): Any grade that has been entered to the " Washers " tab at Home > Project Settings > Job > Nut and Washer Schedule for the selected type (' Hardened ' or ' Bevel ' or ' Load ' or etc.) can be selected on the list box ( ) for this field.

Example: You select F436 as the " Grade " under the " Primary " column of the " Under Head " tab. The result is a line of parametric code that reads: obj.PrimaryHeadWasher.MaterialGrade = "F436" (where obj is the " Object name ").

Quantity ( obj .PrimaryNutWasher.Quantity or obj .SecondaryNutWasher.Quantity or obj .TertiaryNutWasher.Quantity or obj .PrimaryHeadWasher.Quantity or obj .SecondaryHeadWasher.Quantity or obj .TertiaryHeadWasher.Quantity ): The number ( integer >= 0) of washers that are in this position.

Example: You enter 1 as the " Quantity " under the " Primary " column of the " Under Head " tab. The result is a line of parametric code that reads: obj.PrimaryHeadWasher.Quantity = 1 (where obj is the " Object name ").

Thickness ( obj .PrimaryNutWasher.Thickness or obj .SecondaryNutWasher.Thickness or obj .TertiaryNutWasher.Thickness or obj .PrimaryHeadWasher.Thickness or obj .SecondaryHeadWasher.Thickness or obj .TertiaryHeadWasher.Thickness ): The thickness (in mm or inches -- see " Units ") of the square plate or round plate washer.

t = thickness

Example: You enter 0.1 as the " thickness " under the " Primary " column of the " Under Head " tab. The result is a line of parametric code that reads: obj.PrimaryHeadWasher.Thickness = 0.1 (where obj is the " Object name ").

Width ( obj .PrimaryNutWasher.Width or obj .SecondaryNutWasher.Width or obj .TertiaryNutWasher.Width or obj .PrimaryHeadWasher.Width or obj .SecondaryHeadWasher.Width or obj .TertiaryHeadWasher.Width ): The length/width (square washer) or diameter (round plate washer ) in mm or inches -- see " Units ".

w = width

Example: You enter 0.5 as the " Width " under the " Primary " column of the " Under Head " tab. The result is a line of parametric code that reads: obj.PrimaryHeadWasher.Width = 0.5 (where obj is the " Object name ").

Rotation ( obj .PrimaryHeadWasher.Rotation or obj .SecondaryHeadWasher.Rotation or obj .TertiaryHeadWasher.Rotation or obj .PrimaryNutWasher.Rotation or obj .SecondaryNutWasher.Rotation or obj .TertiaryNutWasher.Rotation ): The number of degrees that a square plate washer is rotated.

Hillside washer angle ( obj .HillsideWasherAngle ): The number of degrees that a hillside washer is rotated. This applies when " Hillside " is the selected " Type " of washer.

10.0 degrees 0 degrees -10.0 degrees

To close this window :

"OK" (or the Enter key) closes this window and saves your changes to RAM.

"Cancel" (or the Esc key) closes this window without saving any changes.

"Reset" undoes all changes made to this window since you first opened it. The window remains open.