The Parametric Joist Add window

Warning: For imperial dimensioning, make entries to fields on this window in decimal inches, not fractions. Also, do not use hyphens (-). If you enter a fraction using integers, Python truncates the results of the division operation to an integer (examples: 1/8 = 0 ; 5/4 = 1 ). If you enter fractions with decimal points, Python calculates the precise decimal value (examples: 1.0/8.0 = .125 ; 5.0/4.0 = 1.25 ). If you enter a hyphen, Python interprets the hyphen as a minus sign (examples: 1-2 = -1 ; 3-2 = 1 ).
  •  

Also see :

Quick Notes

------ General settings ------

Section size ( obj . SectionSize or obj.section_size ): " String " plus a string , or " String " plus a variable .

If the box for " String " is checked ( ), you can type in the section size that you want, or you can press the "file cabinet" browse button ( ) and double-click any section that is on the list of available materials in the local shape file . For example, if you were to enter 12k5 , the resulting line of parametric code reads: obj.SectionSize = "12k5" (where obj is the " Object name ").

If the box for " String " is not checked ( ), you can assign this joist the section size of a previously added joist. For example, you could enter jst1.SectionSize to get the section size of a previously named member object called jst1. In the parametric code, the variable will not be in quotes, since the variable itself is not a string, though it returns a string.

Piecemark ( obj . Piecemark or obj.piecemark ): Blank or a user piecemark .

If you leave this blank: No line for assigning a piecemark is included in the code generated by this window. Process and Create Solids assigns a system piecemark to the parametrically added member.

If you enter characters here: Be sure to put them in quotes ("..."). The result is code something like: obj.Piecemark = "my_pcmk" , and this member is assigned my_pcmk as its user piecemark when this script is Run . Warning : If you do this, it is your responsibility to ensure that you Run the script in a Job where there are no members that have already been assigned that piecemark. If you do not properly track user piecemarks, you may get members that are physically quite different but share the same user piecemark.

Tip: A Python script can read piecemarks (user or system) as shown in the following example:

# Prints the piecemark of the member that the user selects.
from member import MemberLocate
from param import ClearSelection
mem1 = MemberLocate("Select a member")
print("The piecemark is: ", mem1.Piecemark)
ClearSelection()

Sequence ( obj . ErectionSequence or obj.sequence ): Any sequence name (a string ) from Home > Project Settings > Job > Zone and Sequence > press " Sequence Names " > Sequence Names .

Example: Entering 2 results in a line of parametric code that reads: obj.ErectionSequence = "2" (where obj is the " Object name ").

Swap ends ( obj . SwapEnds or obj.swap_ends ): ( "Yes" ) or ( "No" ). The choice you make here results in the entry of a string ( "Yes" or "No" ) to the parametric code.

If this box is checked ( ), the box will be checked for " Swap member ends " on the Joist Edit window of the new joist that is generated when this script is Run in Modeling . The parametric code reads: obj.SwapEnds = "Yes" (where obj is the " Object name ").

If the box is not checked ( ), the parametric joist is generated without its ends being swapped.


------ Left end settings ------ | ------ Right end settings ------

Tip : The left end is the " Left end point " end of this joist. Process and Create Solids switches the left and right ends if the " Left end point " is to the right of the " Right end point. " The left end on this window will then be opposite to the left end reported on the Joist Edit window in Modeling .

Input connection type ( obj . LeftEnd.InputConnectionType ) or ( obj . RightEnd.InputConnectionType ): "Plain end" or "Seat" . The choice you make here results in the entry of a string ( "Plain end" or "Seat" ) to the parametric code.

"Plain end" prevents the designing a connection on this end. For the left end, the parametric code reads: obj.LeftEnd.InputConnectionType = "Plain end" (where obj is the " Object name ").

"Seat" designs a seat for the joist top chord. For the left end, the parametric code reads: obj.LeftEnd.InputConnectionType = "Seat" (where obj is the " Object name ").


To close this window :

   

"OK" (or the Enter key) closes this window and saves your changes to RAM.

"Cancel" (or the Esc key) closes this window without saving any changes that you have made to it.

"Reset" undoes all changes made to this window since you first opened it. The window remains open.