The Parametric Round Plate Material window

Most examples on this page are for adding the round plate as a material.

Also see :

Quick Notes

Warning : If your startup code specifies imperial Units("...") , make entries to distance fields on this window in decimal inches, not fractions. Also, do not use hyphens (-). If you enter a fraction using integers, Python truncates the results of the division operation to an integer (examples: 1/8 = 0 ; 5/4 = 1 ). If you enter fractions with decimal points, Python calculates the precise decimal value (examples: 1.0/8.0 = .125 ; 5.0/4.0 = 1.25 ). If you enter a hyphen, Python interprets the hyphen as a minus sign (examples: 1-2 = -1 ; 3-2 = 1 ). See numbers (floating point numbers and integers).

Tips :

To enter a dimension string and convert it to a floating point distance that is properly factored based on the startup code Units("...") , you can use the dim("...") function. See the warning above for an explanation of why the dim() function is needed.


------ General settings ------

Piecemark: You can add a line of code such as obj.MinorMark = "xxx" or obj.Piecemark = "xxx" in a text editor.

For submaterials ( obj . MinorMark or obj.mark ):

If you Run a script that does not include obj.MinorMark , SDS2 piecemarking looks for materials in the current Job that are physically identical to this material and assigns to this material the same submaterial mark assigned to those materials. If no matching materials are found, piecemarking assigns this material a submaterial mark using the appropriate piecemark prefix listed in Home > Project Settings > Fabricator > Member and Material Piecemarking > the " Prefixes " tab.

If you Run a script with obj.MinorMark = "xxx" , SDS2 piecemarking applies that submaterial mark ( xxx ) to the parametrically added material if no other material has yet been assigned that mark. It also applies that mark ( xxx ) if other materials that have that mark ( xxx ) are exactly like the parametrically added material. If the model contains materials with a different submaterial mark ( yyy ) that are exactly like the parametrically added material, the submaterial mark of those materials ( yyy ) is re-named to that of the parametrically added material ( xxx ). If the model contains materials with the same submaterial mark that the script designates to be assigned to the parametrically added material ( xxx ) and those materials are different than the parametrically added material, the submaterial mark in the script is not applied -- instead you get a warning and the parametrically added material is assigned a different submaterial mark using the appropriate piecemark prefix listed in Home > Project Settings > Fabricator > Member and Material Piecemarking > the " Prefixes " tab.

For miscellaneous members ( obj . Piecemark or obj.piecemark ):

If you Run a script that does not include an obj.Piecemark , a system piecemark is assigned to the parametrically added member.

If you Run a script with an obj.Piecemark , be careful. You are responsible for ensuring that members that have been assigned the same user piecemark are physically the same. SDS2 piecemarking does not do this for you.

Tip 1: A Python script can read the submaterial mark of a material as shown in the following example.

# Prints the piecemark of the material the user selects.
from mtrl_list import MtrlLocate
mtrl1 = MtrlLocate("Select material", "Single")
print("The material piecemark is: ", mtrl1.MinorMark)

Tip 2: A script can also read member piecemarks (user or system).

# Prints the piecemark of the member that the user selects.
from member import MemberLocate
from param import ClearSelection
mem1 = MemberLocate("Select a member")
print("The piecemark is: ", mem1.Piecemark)
ClearSelection()

Plate diameter ( obj . PlateDiameter or obj.plate_diameter ): The distance from one edge of the round plate to the opposite edge as measured through the exact center of the round plate. A distance is a floating point number in mm or inches, depending on the startup code Units(' ... ') .

Example 1: Entering a specific diameter sets the diameter of the material to be that specific set value when this script is Run.

Example 2: If you are adding this round plate to a pipe column (defined in the " Member " field) to create a cap plate, entering obj.Member.Depth (where obj is the " Object name ") sets the diameter of the round plate to match the diameter of the " Member ." The result is a line of parametric code that reads: obj.Thickness = obj.Member.Depth .

Material thickness ( obj . Thickness or obj.thick ): The thickness of the plate material. This distance is measured along the material's Z axis . A thickness is a floating point number in mm or inches, depending on the startup code Units(' ... ') .

Example 1: Entering a specific distance sets the thickness of the material to be that specific set value when this script is Run.

Example 2: If you are adding this round plate to a pipe column, then entering obj.Member.Thickness (where obj is the " Object name ") sets the thickness of the round plate to be the wall thickness of the " Member ." The result is a line of parametric code that reads: obj.Thickness = obj.Member.Thickness .

Steel grade ( obj . MaterialGrade or obj.grade ): Any steel grade ( "A36" or "A572" or etc.) from the list of Steel Grades for Plates & Bar Stock can be selected on the menu ( ) for this field.

Example: Selecting A36 results in a line of parametric code that reads: obj.MaterialGrade = "A36" (where obj is the " Object name " and "A36" is a string from the aforementioned setup table).

Thickness reference point ( obj . MaterialOriginPoint or obj.origin ): "FS" or "Center" or "NS" . This sets whether the work points are to the near side, far side or center of the thickness of the material. The work points for the round plate in the example below are both at 100 ft. The choice you make here results in the entry of a string ( "FS" or "Center" or "NS" ) to the parametric code.

"NS" adds the round plate so that its near side is in the plane that includes the workline through the plate's work points. The resulting parametric code reads: obj.MaterialOriginPoint = "NS" (where obj is the " Object name ").

"Center" adds the plate so that its thickness is centered with respect to the workline through the plate's work points. The resulting parametric code reads: obj.MaterialOriginPoint = "Center" .

"FS" adds the plate so that its far side is in the plane that includes the workline through the plate's work points. The resulting parametric code reads: obj.MaterialOriginPoint = "FS" .

Surface finish ( obj . SurfaceFinish or obj.finish ): "None" or "Sand Blasted" or "Red Oxide" or "Yellow Zinc" or "Gray Oxide" or "Blued Steel" or "Galvanized" can be selected on the list box ( ) for this field. The choice you make here results in the entry of a string to the parametric code.

Sand Blasted Red Oxide Yellow Zinc
Gray Oxide Blued Steel Galvanized
The colors of materials erection views in ' Drawing Editor on Solid ' are based on their surface finish.

Example: Selecting Yellow Zinc results in a line of parametric code that reads: obj.SurfaceFinish = "Yellow Zinc" (where obj is the " Object name ").

Also note: When you export a KISS file using ' Model ' as the " Data source ," surface finish data on materials are compiled into the P lines in the KISS download. Surface finish data can also be output to a fabtrol_assembly_parts_list.XSR file.

Color ( obj . MaterialColor3d or obj.color ): A "named_color" or a custom color . The choice you make here assigns three values (RGB values) from 0 to 255, which define the color of the round plate when it is displayed in one of the three solid forms .

The "named_colors" are set up on the Predefined Colors window. The color swatch next to the list box ( ) displays the color that is selected. Example : Selecting Medium_beam results in a line of parametric code that reads: obj.MaterialColor3d = "Medium_beam" (where obj is the " Object name ").

Select Custom Color (last option on the menu) to launch your operating system's color picker and define any color you like. Example: Selecting a custom color results in a line of parametric code that reads: obj.MaterialColor3d = (r, g, b) where r or g or b is an integer value from 0 to 255 and obj is the " Object name ."


Bottom row of buttons :

     

" General Information " opens the Parametric General Information window so that you can assign a " Description " or " Material usage description " or " Material routing " to this material. Making entries to the Parametric General Information window adds extra lines to the parametric code. Those extra lines override default settings.

"OK" (or the Enter key) closes this window and saves your changes to RAM.

"Cancel" (or the Esc key) closes this window without saving any changes.

Regardless of whether you are performing an Add or Edit operation, " Cancel " ends the operation.

"Reset" undoes all changes made to this window since you first opened it. The window remains open.