The Parametric Rolled Plate Material window

Also see :

Quick Notes

Warning : If your startup code specifies imperial Units("...") , make entries to distance fields on this window in decimal inches, not fractions. Also, do not use hyphens (-). If you enter a fraction using integers, Python truncates the results of the division operation to an integer (examples: 1/8 = 0 ; 5/4 = 1 ). If you enter fractions with decimal points, Python calculates the precise decimal value (examples: 1.0/8.0 = .125 ; 5.0/4.0 = 1.25 ). If you enter a hyphen, Python interprets the hyphen as a minus sign (examples: 1-2 = -1 ; 3-2 = 1 ). See numbers (floating point numbers and integers).

Tips :


------ General settings ------

Piecemark: You can add a line of code such as obj.MinorMark = "xxx" or obj.Piecemark = "xxx" in a text editor.

For submaterials ( obj . MinorMark or obj.mark ):

If you Run a script that does not include obj.MinorMark , SDS2 piecemarkinglooks for materials in the current Job that are physically identical to this material and assigns to this material the same submaterial mark assigned to those materials. If no matching materials are found, piecemarking assigns this material a submaterial mark using the appropriate piecemark prefix listed in Home > Project Settings > Fabricator > Member and Material Piecemarking > the " Prefixes " tab.

If you Run a script with obj.MinorMark = "xxx" , SDS2 piecemarking applies that submaterial mark ( xxx ) to the parametrically added material if no other material has yet been assigned that mark. It also applies that mark ( xxx ) if other materials that have that mark ( xxx ) are exactly like the parametrically added material. If the model contains materials with a different submaterial mark ( yyy ) that are exactly like the parametrically added material, the submaterial mark of those materials ( yyy ) is re-named to that of the parametrically added material ( xxx ). If the model contains materials with the same submaterial mark that the script designates to be assigned to the parametrically added material ( xxx ) and those materials are different than the parametrically added material, the submaterial mark in the script is not applied -- instead you get a warning and the parametrically added material is assigned a different submaterial mark using the appropriate piecemark prefix listed in Home > Project Settings > Fabricator > Member and Material Piecemarking > the " Prefixes " tab.

For miscellaneous members ( obj . Piecemark or obj.piecemark ):

If you Run a script that does not include an obj.Piecemark , a system piecemark is assigned to the parametrically added member.

If you Run a script with an obj.Piecemark , be careful. You are responsible for ensuring that members that have been assigned the same user piecemark are physically the same. SDS2 piecemarking does not do this for you.

Tip 1: A Python script can read the submaterial mark of a material as shown in the following example.

# Prints the piecemark of the material the user selects.
from mtrl_list import MtrlLocate
mtrl1 = MtrlLocate("Select material", "Single")
print("The material piecemark is: ", mtrl1.MinorMark)

Tip 2: A script can also read member piecemarks (user or system).

# Prints the piecemark of the member that the user selects.
from member import MemberLocate
from param import ClearSelection
mem1 = MemberLocate("Select a member")
print("The piecemark is: ", mem1.Piecemark)
ClearSelection()

Material thickness ( obj . Thickness or obj.thick ): The thickness of the plate material. A thickness is a floating point number in mm or inches, depending on the startup code Units(' ... ') . This distance is measured along the material's Z axis .

Example 1: Entering a specific distance sets the thickness of the material to be that specific value when this script is Run.

Example 2: Entering obj.Member.WebThickness (where obj is the " Object name ") sets the thickness of the rolled plate to be the web thickness of the " Member ." The result is a line of parametric code that reads: obj.Thickness = obj.Member.WebThickness .

Material width ( obj . Width or obj.width ): The width of the plate. A width a floating point number in mm or inches, depending on the startup code Units(' ... ') . This distance is measured along the plate's Y material axis and is the same on both its left and right ends.

Note: This dimension is automatically calculated based on the " Outside radius " and " Included angle ." The width you enter here appears in the parametric code; however, when that code is Run , the actual width of the rolled plate that is generated will be the calculated width, probably not the width entered here.

Material length ( obj . OrderLength or obj.length ): The length of the material along its longitudinal axis ( X material axis ). A length is a floating point number in mm or inches, depending on the startup code Units(' ... ') .

Example 1: Entering a specific distance sets the length of the material to be that value when this script is Run.

Example 2: Changing the material length causes the difference to be added to/subtracted from the end of the rolled plate that is opposite to the first work point that was located.

Work point distance ( obj . WorkpointSlopeDistance or obj.work_pt_dist ): In most cases, this distance is the same as the " Material length ." However, in the case of a tapered rolled plate (where a value for " Outside tapered radius " has been entered), this distance is different than the " Material length ." A distance is a floating point number in mm or inches, depending on the startup code Units(' ... ') .

Outside radius ( obj . OutsideRadius or obj.outside_radius ): The distance along the edge of the rolled plate to the center of an imaginary circle extrapolated from the outside edges of the rolled plate. A distance is a floating point number in mm or inches, depending on the startup code Units(' ... ') .

Note: The " Outside radius " must be measured from the end of the rolled plate where the first work point was located if an " Outside tapered radius " other than zero has been entered.

Outside tapered radius ( obj . TaperRadius or obj.taper_radius ): 0 or a distance specifying the radius of the rolled plate from the end opposite to where the first work point was located. A distance is a floating point number in mm or inches, depending on the startup code Units(' ... ') .

Enter 0 or the exact same distance entered to " Outside radius " if you do not want the rolled plate to be tapered.

Enter a distance (other than that entered to " Outside radius ") if you want the rolled plate to be tapered. " Outside tapered radius " works the same way as " Outside radius ," except that this distance is measured from the end of the rolled plate opposite to the first work point .

Included angle ( obj . IncludedAngle or obj.bend_angle ): Any positive angle (a floating point number ) from 0.1 to 360.0 degrees.

This is the number of degrees taken up by the arc of the rolled plate (the length of the radius of this arc is defined by the " Outside radius "). The entry you make here directly affects the " Material width " of the rolled plate.

Fabrication method ( obj . RollType or obj.fab_method ): Continuous Rolling or Segmented Bending . The choice you make here results in the entry of a string ( "Continuous Rolling" or "Segmented Bending" ) to the parametric code.

Continuous Rolling sets the curve of the rolled plate to be smooth, continuous and parabolic. The resulting parametric code reads: obj.RollType = "Continuous Rolling" (where obj is the " Object name ").

Segmented Bending causes the rolled plate to be a series of flat (not-curved) bend segments that together approximate a parabola. You need to enter a number of " Bend segments ." The resulting parametric code reads: obj.RollType = "Segmented Bending" .

Bend segments ( obj . BendSegments or obj.bend_segments ): 0 or an integer of 3 or greater .

0 should be entered when " Continuous Rolling " is selected. Entering 0 results in a line of parametric code that reads: obj.BendSegments = 0 (where obj is the " Object name ").

An entry of 3 or greater applies when " Segmented Bending " is selected. The more segments you enter, the more closely the rolled plate approximates a continuous parabolic curve.

Steel grade ( obj . MaterialGrade or obj.grade ): Any steel grade ( A36 or A572 or etc.) from the list of Steel Grades for Plates & Bar Stock can be selected on the menu ( ) for this field.

Example: Selecting A36 results in a line of parametric code that reads: obj.MaterialGrade = "A36" (where obj is the " Object name " and "A36" is a string from the aforementioned setup table).

Surface finish ( obj . SurfaceFinish or obj.finish ): "None" or "Sand Blasted" or "Red Oxide" or "Yellow Zinc" or "Gray Oxide" or "Blued Steel" or "Galvanized" can be selected on the list box ( ) for this field. The choice you make here assigns the selected string as the SurfaceFinish attribute in the parametric code.

Sand Blasted Red Oxide Yellow Zinc
Gray Oxide Blued Steel Galvanized
  The colors of materials on Drawing Editor erection views in ' Solid ' are based on their surface finish.

Example: Selecting Yellow Zinc results in a line of parametric code that reads: obj.SurfaceFinish = "Yellow Zinc" (where obj is the " Object name ").

Also note: When you export a KISS file using Model as the " Data source ," surface finish data on materials are compiled into the P lines in the KISS download. Surface finish data can also be output to a fabtrol_assembly_parts_list.XSR file.

Color ( obj . MaterialColor3d or obj.color ): A "named_color" or a custom color . The choice you make here assigns three values (RGB values) from 0 to 255, which define the color of the rolled plate when it is displayed in one of the three solid forms .

The predefined colors are set up on the Predefined Colors window. The color swatch next to the list box ( ) displays the color that is selected. Example: Selecting Medium_beam results in a line of parametric code that reads: obj.MaterialColor3d = "Medium_beam" (where obj is the " Object name ").

Select Custom Color (last option on the menu) to launch your operating system's color picker and define any color you like. Example: Selecting a custom color results in a line of parametric code that reads: obj.MaterialColor3d = (r, g, b) where r or g or b is an integer value from 0 to 255 and obj is the " Object name ".

Centered ( obj . Centered or obj.centered ):  ( "Yes" ) or  ( "No" ). This option positions the rolled plate with respect to the first work point located when this rolled plate was added. In the parametric code, it results in the entry of a string ( "Yes" or "No" ).

If this box is checked ( ), the rolled plate is positioned so that point 1 is at the vertex of the outside radii of the rolled plate. The resulting parametric code reads: obj.Centered = "Yes" (where obj is the " Object name ").

If the box is not checked ( ), the rolled plate is positioned so that point 1 is the material's most outside point. The resulting parametric code reads: obj.Centered = "No" (where obj is the " Object name ").


Bottom row of buttons :

     

" General Information " opens the Parametric General Information window so that you can assign a " Description " or " Material usage description " or " Material routing " to this material. Making entries to the Parametric General Information window adds extra lines to the parametric code. Those extra lines override default settings.

"OK" (or the Enter key) closes this window and saves your changes to RAM.

"Cancel" (or the Esc key) closes this window without saving any changes.

"Reset" undoes all changes made to this window since you opened it. The window remains open.