The Parametric Turnbuckle Material window

Quick Notes

Options :

Also see :


------ General settings ------

Section size ( obj . SectionSize or obj.section_size ): Any turnbuckle section that is listed in the local shape file . If the box for " Section size " is checked ( ), validation confirms that your entry is in the local shape file and does not let you Tab out of the field if it is not. If the box is not checked ( ), you can enter a variable or expression that will return a string from the local shape file.

To enter a section size: With " String " checked ( ), you can type in the section size that you want. Or you can press the "file cabinet" browse button ( ) and double-click any section that is on the list of available turnbuckle sections that are in the local shape file . For example, if you enter TB3/8x6 ,- the resulting line of parametric code reads: obj.SectionSize = "TB3/8x6" (where obj is the " Object name "). Note from this example that you do not have to put the section size string in quotes.

To enter a variable : With " String " not checked ( ), you can enter a variable or expression that will return a string that is the section size of a turnbuckle. For example, if you previously added a turnbuckle with the " Object name " of tbk1 and this turnbuckle is tbk2 and you want this turnbuckle to be assigned the same section size as tbk1 , you could change the entry to this field to tbk1.SectionSize . The resulting line of parametric code would read: tbk2.SectionSize = tbk1.SectionSize . Note from this example that tbk1.SectionSize is not in quotes, since tbk1.SectionSize itself is not a string, though it returns a string.

Piecemark : You can add a line of code such as obj.MinorMark = "xxx" or obj.Piecemark = "xxx" in a text editor.

For submaterials ( obj . MinorMark or obj.mark ):

If you Run a script that does not include obj.MinorMark , SDS2 piecemarking looks for materials in the current Job that are physically identical to this material and assigns to this material the same submaterial mark assigned to those materials. If no matching materials are found, the material is assigned a submaterial mark using the appropriate piecemark prefix listed in Home > Project Settings > Fabricator > Member and Material Piecemarking > the " Prefixes " tab.

If you Run a script with obj.MinorMark = "xxx" , SDS2 piecemarking applies that submaterial mark ( xxx ) to the parametrically added material if no other material has yet been assigned that mark. It also applies that mark ( xxx ) if other materials that have that mark ( xxx ) are exactly like the parametrically added material. If the model contains materials with a different submaterial mark ( yyy ) that are exactly like the parametrically added material, the submaterial mark of those materials ( yyy ) is re-named to that of the parametrically added material ( xxx ). If the model contains materials with the same submaterial mark that the script designates to be assigned to the parametrically added material ( xxx ) and those materials are different than the parametrically added material, the submaterial mark in the script is not applied -- instead you get a warning and the parametrically added material is assigned a different submaterial mark using the appropriate piecemark prefix listed in Home > Project Settings > Fabricator > Member and Material Piecemarking > the " Prefixes " tab.

For miscellaneous members ( obj . Piecemark or obj.piecemark ):

If you Run a script that does not include an obj.Piecemark , a system piecemark is assigned to the parametrically added member.

If you Run a script with an obj.Piecemark , be careful. You are responsible for ensuring that members that have been assigned the same user piecemark are physically the same. SDS2 piecemarking does not do this for you.

Tip 1: A Python script can read the submaterial mark of a material as shown in the following example.

# Prints the piecemark of the material the user selects.
from mtrl_list import MtrlLocate
mtrl1 = MtrlLocate("Select material", "Single")
print("The material piecemark is: ", mtrl1.MinorMark)

Tip 2: A script can also read member piecemarks (user or system).

# Prints the piecemark of the member that the user selects.
from member import MemberLocate
from param import ClearSelection
mem1 = MemberLocate("Select a member")
print("The piecemark is: ", mem1.Piecemark)
ClearSelection()

Left thread type ( obj . ThreadTypeLeftEnd or obj.thread_type_left ): "None" or "Left handed" or "Right handed" . Other than in the Report Writer and on the Turnbuckle Material window, this information is not referenced in SDS2 programs. In the parametric code, the choice you make is designated with a string ( "None" or "Left handed" or "Right handed" ).

Example: Selecting Left handed results in a line of parametric code that reads: tbk1.ThreadTypeLeftEnd = "Left handed" (where obj is the " Object name ").

Right thread type ( obj . ThreadTypeRightEnd or obj.thread_type_right ): "None" or "Left handed" or "Right handed" . Other than in the Report Writer and on the Turnbuckle Material window, this information is not referenced in SDS2 programs. In the parametric code, the choice you make is designated with a string ( "None" or "Left handed" or "Right handed" ).

Example: Selecting Left handed results in a line of parametric code that reads: tbk1.ThreadTypeRightEnd = "Left handed" (where obj is the " Object name ").

Surface finish ( obj . SurfaceFinish or obj.finish ): "None" or "Sand Blasted" or "Red Oxide" or "Yellow Zinc" or "Gray Oxide" or "Blued Steel" or "Galvanized" can be selected on the list box ( ) for this field. The choice you make here assigns the selected string as the SurfaceFinish attribute for this " Object name " in the parametric code.

Sand Blasted Red Oxide Yellow Zinc
Gray Oxide Blued Steel Galvanized
The colors of materials on Drawing Editor erection views in ' Solid ' are based on their surface finish.

Example: Selecting Yellow Zinc results in a line of parametric code that reads: obj.SurfaceFinish = "Yellow Zinc" (where obj is the " Object name ").

Also note: When you export a KISS file using Model as the " Data source ," surface finish data on materials are compiled into the P lines in the KISS download. Surface finish data can also be output to a fabtrol_assembly_parts_list.XSR file.

Color ( obj . MaterialColor3d or obj.color ): A "named_color" or a custom color . The choice you make here assigns three values (RGB values) from 0 to 255, which define the color of the turnbuckle when it is displayed in one of the three solid forms .

The "named_colors" are set up on the Predefined Colors window. The color swatch next to the list box ( ) displays the color that is selected. Example: Selecting Medium_beam results in a line of parametric code that reads: obj.MaterialColor3d = "Medium_beam" (where obj is the " Object name ").

Select Custom Color (last option on the menu) to launch your operating system's color picker and define any color you like. Example: Selecting a custom color results in a line of parametric code that reads: obj.MaterialColor3d = (r, g, b) where r or g or b is an integer value from 0 to 255 and obj is the " Object name ."


Bottom row of buttons :

     

"OK" (or the Enter key) closes this window and saves your changes to RAM.

"Cancel" (or the Esc key) closes this window without saving any changes.

"Reset" undoes all changes made to this window since you first opened it. The window remains open.