The Parametric Girt Add window

Quick Notes

About this window :

Also see :

Warning : If you are using imperial dimensioning, make entries to fields on this window in decimal inches, not fractions. Also, do not use hyphens (-). If you enter a fraction using integers, Python truncates the results of the division operation to an integer (examples: 1/8 = 0 ; 5/4 = 1 ). If you enter fractions with decimal points, Python calculates the precise decimal value (examples: 1.0/8.0 = .125 ; 5.0/4.0 = 1.25 ). If you enter a hyphen, Python interprets the hyphen as a minus sign (examples: 1-2 = -1 ; 3-2 = 1 ). See numbers (floating point numbers and integers). Also see Units("...") , which set whether you need to enter dimensions in decimal inches or millimeters.


------ General settings ------

Section size ( obj . SectionSize or obj.section_size ): ' String ' plus a string , or " String " plus a variable . Wide flange , channel , welded plate W and tube sections are valid section sizes for girts.

If the box for " String " is checked ( ), you can type in the section size that you want, or you can press the "file cabinet" browse button ( ) and double-click any section that is on the list of available materials in the local shape file . For example, if you were to enter W14x90 , the resulting line of parametric code reads: obj.SectionSize = "W14x90" (where obj = object ).

If the box for " String " is not checked ( ), you can assign this girt the section size of a previously added material or member main material. For example, you could enter girt1.SectionSize to get the section size of a previously named member object called girt1. In the parametric code, the variable will not be in quotes, since the variable itself is not a string, though it returns a string.

Piecemark ( obj . Piecemark or obj.piecemark ): Blank or a user piecemark .

If you leave this blank: No line for assigning a piecemark is included in the code generated by this window. A system piecemark is assigned to the parametrically added member during Process and Create Solids .

If you enter characters here: Be sure to put them in quotes ("..."). The result is code something like: obj.Piecemark = "my_pcmk" , and this member is assigned my_pcmk as its user piecemark at the time this script is Run . Warning : If you do this, it is your responsibility to ensure that you Run the script in a Job where there are no members that have already been assigned that piecemark. If you do not properly track user piecemarks, you may get members that are physically quite different but share the same user piecemark.

Tip: A Python script can read piecemarks (user or system) as shown in the following example:

# Prints the piecemark of the member that the user selects.
from member import MemberLocate
from param import ClearSelection
mem1 = MemberLocate("Select a member")
print("The piecemark is: ", mem1.Piecemark)
ClearSelection()

Steel grade ( obj . MaterialGrade or obj.grade ): Any steel grade ( "A36" or "A572" or etc.) from the list of " Wide Flange Grades " (for wide flange girts) or " Channel Grades " (for channel girts) or " HSS/TS Grades " (for tube girts).

Example: Selecting A36 results in a line of parametric code that reads: obj.MaterialGrade = "A36" (where obj is the " Object name " and "A36" is a string from one of the aforementioned setup tables).

Sequence ( obj . ErectionSequence or obj.sequence ): Any sequence name (a string ) from Home > Project Settings > Job > Zone and Sequence > press " Sequence Names " > Sequence Names .

Example: Entering 2 results in a line of parametric code that reads: obj.ErectionSequence = "2" (where obj is the " Object name ").

Camber ( obj . Camber or obj.camber ): Not applicable at this time.

Girt rotation ( obj . Rotation or obj.rotation ): A positive or negative floating point number of degrees of rotation ( 90.0 to - 90.0 ) from web vertical. If you are looking along the member workline toward the left end of the member, a positive entry rotates the member counterclockwise that number of degrees.

0 (zero) degrees sets the web of the girt to be vertical.

-90.0 sets the web of the girt to be horizontal. The near side of the girt faces toward you in a plan view.

90.0 sets the web of the girt to be horizontal. The far side of the girt faces toward you in a plan view.

Long leg ( obj . LongLegOfAngleIsVertical or obj.LLV ): Vertical ("VT.") or Horizontal ("HZ."). This applies when the " Section size " is an angle. The choice you make here results in the entry of a string ( "VT." or "HZ." ) to the parametric code.

Vertical orients the long leg of the angle(s) vertically when 90.0 or - 90.0 is the " Girt rotation ." The parametric code reads: obj.LongLegOfAngleIsVertical = "VT." (where obj is the " Object name ").

Horizontal orients the long leg of the angle(s) horizontally when 90.0 or - 90.0 is the " Girt rotation ." The parametric code reads: obj.LongLegOfAngleIsVertical = "HZ." (where obj is the " Object name ").

Toe direction ( obj . ToeIO or obj.toeio ): "Up" or "Down" . This applies when the " Section size " is a single channel or angle. The choice you make here results in the entry of a string ( "Up" or "Down" ) to the parametric code.

"Up" points the toe(s) of the angle (or channel) up in a plan view if the " Girt rotation " is 90.0 degrees. The parametric code reads: obj.ToeIO = "Up" (where obj is the " Object name ").

"Down" points the toe(s) of the angle (or channel) down in a plan view if the " Girt rotation " is 90.0 degrees. The parametric code reads: obj.ToeIO = "Down" (where obj is the " Object name ").

Please note: If the " Girt rotation " is -90.0 degrees, " Up " points the toe(s) of the angle (or channel) down.

Swap ends ( obj . SwapEnds or obj.swap_ends ): ( "Yes" ) or ( "No" ). The choice you make here results in the entry of a string ( "Yes" or "No" ) to the parametric code.

If this box is checked ( ), the box will be checked for " Swap member ends " on the Girt (Legacy) Edit window of the new girt that is generated when this script is Run in Modeling . The parametric code reads: obj.SwapEnds = "Yes" (where obj is the " Object name ").

If the box is not checked ( ), the parametric girt is generated without its ends being swapped.


------ Left end settings ------ | ------ Right end settings ------

Tip 1: The left end is the " Left end point " end of this member. Process and Create Solids switches the left and right ends if the " Left end point " is to the right of the " Right end point. " Tip 2: Additional attributes not on this window are available for left/right setbacks and left/right end reactions .

Input connection type ( obj . LeftEnd.InputConnectionType ) or ( obj . RightEnd.InputConnectionType ): "Plain end" .

Plain end prevents the designing of a connection on this end. Process and Create Solids automatically copes and sets back a girt with a "Plain end" . For the left end, the parametric code reads: obj.LeftEnd.InputConnectionType = "Plain end" (where obj is the " Object name ").


To close this window :

   

"OK" (or the Enter key) closes this window and saves your changes to RAM.

"Cancel" (or the Esc key) closes this window without saving any changes that you have made to it.

"Reset" undoes all changes made to this window since you first opened it. The window remains open.