The Parametric Vertical Brace Add window

Quick Notes

Options :

Step-by-step instructions :

Also see :

Warning : If you are using imperial dimensioning, make entries to fields on this window in decimal inches, not fractions. Also, do not use hyphens (-). If you enter a fraction using integers, Python truncates the results of the division operation to an integer (examples: 1/8 = 0 ; 5/4 = 1 ). If you enter fractions with decimal points, Python calculates the precise decimal value (examples: 1.0/8.0 = .125 ; 5.0/4.0 = 1.25 ). If you enter a hyphen, Python interprets the hyphen as a minus sign (examples: 1-2 = -1 ; 3-2 = 1 ). See numbers (floating point numbers and integers). Also see Units("...") , which set whether you need to enter dimensions in decimal inches or millimeters.


------ General settings ------

Section size ( obj . SectionSize or obj.section_size ): " String " plus a string , or " String " plus a variable. Connection design can create connections for wide flange , welded plate wide flange , W tee , HSS round and HSS rectangular vertical braces.

If the box for " String " is checked ( ), you can type in the section size that you want, or you can press the "file cabinet" browse button ( ) and double-click any section that is on the list of available materials in the local shape file . For example, if you were to enter L5x3x3/8 , the resulting line of parametric code reads: obj.SectionSize = "L5x3x3/8" (where obj = object ).

If the box for " String " is not checked ( ), you can assign this vertical brace the section size of a previously added material or member main material. For example, you could enter mem1.SectionSize to get the section size of a previously named member object called mem1. In the parametric code, the variable will not be in quotes, since the variable itself is not a string, though it returns a string.

Piecemark ( obj . Piecemark or obj.piecemark ): Blank or a user piecemark .

If you leave this blank: No line for assigning a piecemark is included in the code generated by this window. SDS2 piecemarking assigns a system piecemark to the parametrically added member during Process and Create Solids .

If you enter characters here: Be sure to put them in quotes ("..."). The resulting code is something like: obj.Piecemark = "my_pcmk" , and this member is assigned my_pcmk as its user piecemark at the time this script is Run . Warning : If you do this, it is your responsibility to ensure that you Run the script in a Job where there are no members that have already been assigned that piecemark. If you do not properly track user piecemarks, you may get members that are physically quite different but share the same user piecemark.

Tip: A Python script can read piecemarks (user or system) as shown in the following example:

# Prints the piecemark of the member that the user selects.
from member import MemberLocate
from param import ClearSelection
mem1 = MemberLocate("Select a member")
print("The piecemark is: ", mem1.Piecemark)
ClearSelection()

Steel grade ( obj . MaterialGrade or obj.grade ): Any steel grade ( "A36" or "A572" or etc.) from the list of Angle Grades (for angle vertical braces) or " Wide Flange Grades " (for wide flange vertical braces) or " Pipe Grades " (for HSS round vertical braces) or " HHS / TS Grades " (for HSS rectangular vertical braces).

Example: Selecting A36 results in a line of parametric code that reads: obj.MaterialGrade = "A36" (where obj is the " Object name " and "A36" is a string from one of the aforementioned setup tables).

Sequence ( obj . ErectionSequence or obj.sequence ): Any sequence name (a string ) from Home > Project Settings > Job > Zone and Sequence > press " Sequence Names " > Sequence Names .

Example: Entering 2 results in a line of parametric code that reads: obj.ErectionSequence = "2" (where obj is the " Object name ").

Long leg ( obj . LongLegOfAngleIsVertical or obj.LLV ): "Outstanding" or "To gusset" . This applies when the " Section size " is an angle with unequal legs. The choice you make here results in the entry of a string ( "Outstanding" or "To gusset" ) to the parametric code.

"Outstanding"
"To gusset"

"Outstanding" bolts the short leg of the angle brace to the gusset plate, with the long leg outstanding. The parametric code reads: obj.LongLegOfAngleIsVertical = "Outstanding" (where obj is the " Object name ").

"To gusset" bolts the long leg of the angle vertical brace to the gusset plate. The parametric code reads: obj.LongLegOfAngleIsVertical = "To gusset" (where obj is the " Object name ").

Web orientation ( obj . WebOrient or obj.web_orient ): Vertical ( "VT." ) or Horizontal ( "HZ." ). This applies only when wide flange or welded plate wide flange material is entered as the " Section size ." The choice you make here results in the entry of a string ( "VT." or "HZ." ) to the parametric code.

"VT."
"HZ."

"VT." makes the web of the brace vertical to the world. The parametric code reads: obj.WebOrient = "VT." (where obj is the " Object name ").

"HZ." makes the web of the brace horizontal to the world. The parametric code reads: obj.WebOrient = "HZ." (where obj is the " Object name ").

Long side ( obj . LongSide or obj.long_side ): Vertical ( "VT." ) or Horizontal ( "HZ." ). This applies when a tube material has been entered as the " Section size ." The choice you make here results in the entry of a string ( "VT." or "HZ." ) to the parametric code.

"VT."
"HZ."

"VT." makes the long side of the tube vertical. The parametric code reads: obj.LongSide = "VT." (where obj is the " Object name ").

"HZ." makes the long side of the tube horizontal. The parametric code reads: obj.LongSide = "HZ." (where obj is the " Object name ").

One gage line ( obj . OneGageLineOfBoltsOnBrace or obj.one_gage_line ): ( "Yes" ) or ( "No" ). This applies when the " Section size " is an angle . The choice you make here results in the entry of a string ( "Yes" or "No" ) to the parametric code.

One gage line
One gage line

If this box is checked ( ), connection design creates a single column of bolts to connect the angle to the gusset. This may result in a gusset plate that is larger or thicker. The parametric code reads: obj.OneGageLineOfBoltsOnBrace = "Yes" (where obj is the " Object name ").

If the box is not checked ( ), connection design creates two columns of bolts to connect the angle to the gusset when the length of the angle leg to the gusset is greater than 5 inches (127 mm). The parametric code reads: obj.OneGageLineOfBoltsOnBrace = "No" (where obj is the " Object name ").

Stagger bolts ( obj . StaggerBoltsAtAngleBraceConnections or obj.stagger_bolts ): ( "Yes" ) or ( "No" ). This applies when the " Section size " is an angle and the leg to gusset is 5 inches (127 mm) or longer. The choice you make here results in the entry of a string ( "Yes" or "No" ) to the parametric code.

Stagger bolts
Stagger bolts

If this box is checked ( ), connection design staggers the bolts that connect the angle to the gusset. The parametric code reads: obj.StaggerBoltsAtAngleBraceConnections = "Yes" (where obj is the " Object name ").

If the box is not checked ( ), connection design creates two columns of non-staggered bolts to connect the angle brace to the gusset. The parametric code reads: obj.StaggerBoltsAtAngleBraceConnections = "No" (where obj is the " Object name ").

Stem orientation ( obj . StemOrientation or obj.stem_orient ): Horizontal ( "HZ." ) or Vertical ( "VT." ). This applies when the " Section size " is a W tee or S tee section. The choice you make here results in the entry of a string ( "HZ." or "VT." ) to the parametric code.

"HZ."
"VT."

"HZ." bolts the flange of the tee directly to the gusset. The top flange center line of the tee aligns with the work line of the brace.

"VT." shop bolts the stem (web) of the tee to the gusset. The bottom bolt line aligns with the workline of the brace if the stem is "Up" (as shown). The top bolt line aligns with the workline if the stem is "Down" .

Stem direction ( obj . StemDirection or obj.stem_direction ): "Up" or "Down" . This applies to a W tee vertical brace whose " Stem orientation " is " VT ". The choice you make here results in the entry of a string ( "Up" or "Down" ) to the parametric code.

"Up"
"Down"

"Up" points the stem (web) up on the W tee or S tee brace. The bottom bolt line of the connection aligns with the work line of the brace.

"Down" points the stem (web) down on the W tee or S tee brace. The top bolt line of the connection aligns with the work line of the brace.

Double material ( obj . DoubleMaterial or obj.is_double ): ( "Yes" ) or ( "No" ). This applies when the " Section size " is an angle or channel. The choice you make here results in the entry of a string ( "Yes" or "No" ) to the parametric code.

If this box is checked ( ), the vertical brace main material is double material (back-to-back or in a star configuration). The parametric code reads: obj.DoubleMaterial = "Yes" (where obj is the " Object name ").

If the box is not checked ( ), the vertical brace is a single angle or channel. The parametric code reads: obj.DoubleMaterial = "No" (where obj is the " Object name ").

Side of gusset ( obj . SideOfGusset or obj.side_of_guss ): Near ( "Near side" ) or Far ( "Far side" ). This applies to W tee , angle or channel vertical braces. The choice you make here results in the entry of a string ( "Near side" or "Far side" ) to the parametric code.

"Near side"
"Far side"

"Near side" points the toe of the flange toward you when you are facing the near side of the material. The near side of a vertical brace is the side facing you when the brace's left end is to your left. The parametric code reads: obj.SideOfGusset = "Near side" (where obj is the " Object name ").

"Far side" points the toe of the flange away from you when you are facing the near side of the material. The parametric code reads: obj.SideOfGusset = "Far side" (where obj is the " Object name ").

Configuration ( obj . Configuration or obj.configuration ): "Back to back" or "Star" . This option applies when the box for " Double material " is checked. The " Type of spacer " that is applied during Process and Create Solids is specified in Detail Members and Fabricator Options . The choice you make here results in the entry of a string ( "Back to back" or "Star" ) to the parametric code.

"Back to back"
"Star"

"Back to back" lays the two angles back-to-back with a spacer (stitch plate) in between. The parametric code reads: obj.Configuration = "Back to back" (where obj is the " Object name ").

"Star" lays the two angles in a star configuration using vertical spacers (stitch plates). The parametric code reads: obj.SideOfGusset = "Star" (where obj is the " Object name ").

Locate on neutral axis ( obj . PlaceAngleBracesOnNeutralAxisDescription or obj.neutral_axis ): "Automatic" or "Yes" or "No" .This applies when the " Section size " is an angle . Regardless of the selection made here, the work line of the vertical brace runs along the surface of the angle leg that attaches to the gusset. In the parametric code, the choice made here is designated with a string ( "Automatic" or "Yes" or "No" ).

workline ( x )
on neutral axis
workline ( x )
on gage line
 

"Automatic" applies the choice made to " Locate angle braces on neutral axis " in Member Detailing & Fabrication Options (setup).

"Yes " causes the angle material's X-X axis or Y-Y axis (shown in the AISC Structural Shapes tables) to intersect with the workline of the brace.

"No" aligns the gage line of the angle material with the workline of the brace. An angle's gage line is the " Long leg gage " or " Short leg gage " entered in the local shape file .

Min gusset thickness ( obj . UserInputMinGussetThickness or obj.min_guss_thick ): Auto (blank) or the minimum thickness (a floating point number in the startup code " Units ") of the gusset plate.

If " Auto " is checked ( ), no line for the minimum gusset thickness appears in the code. " Minimum gusset thickness " on the Vertical Brace Edit window of the parametrically added brace is automatically set to " Auto ," and connection design appllies the " Minimum gusset plate thickness " in Standard Fabricator Connections (setup) when that parametrically added brace undergoes Process and Create Solids .

If " Auto " is not checked ( ), connection design creates a gusset plate that is as thick or thicker than the thickness that is entered here.

Warning : Click here before entering a distance.

Stitch plate gap ( obj . StitchPlateGap or obj.stitch_pl_gap ): Auto (blank) or the distance (a floating point number in the startup code " Units ") between the double-angle or double-channel braces.

Warning : Do not enter values like those shown in this illustration. Click here before entering a distance.

Auto results in no line for the stitch plate gap appearing in the code. " Stitch plate gap " on the Vertical Brace Edit window of the parametrically added brace is automatically set to " Auto ," and connection design generates a gap that is equal to the gusset plate thickness when the brace undergoes Process and Create Solids .

If the box for " Auto " is not checked ( ), then the distance that is entered here sets the gap that separates the two angles or channels that make up the double-material brace.

Warning : Click here before entering a distance.

Stitch plate spacing ( obj . StitchPlateSpacing or obj.stitch_pl_spa ): Auto (blank) or the center-to-center distance (a floating point number in the startup code " Units ") between stitch plates and the left/right end of the brace. Left/right end = end of the brace material for a plain end connection. Left/right end = inside bolt if the end has a gusset.

   s = spacing

Auto results in no line for the stitch plate spacing appearing in the code. " Max stitch plate spacing " on the Vertical Brace Edit window of the parametrically added brace is automatically set to " Auto ."

If the box for " Auto " is not checked ( ), then " Auto " must be checked for " Number of stitch plates " if you want the SDS2 program that runs the parmetric script you are creating to generate the minimum number of stitch plates that are required to achieve a spacing that is close as possible to the distance that is entered here.

Warning : Click here before entering a distance.

Number of stitch plates ( obj . StitchPlateNumber or obj.num_stitch_plates ): Auto (blank) or the number (a positive integer : 1 or 2 or ...) of stitch plates.

Auto results in no line for the number of stitch plates appearing in the code. " Number of stitch plates " on the Vertical Brace Edit window of the parametrically added brace is automatically set to " Auto ."

If the box for " Auto " is not checked ( ), then " Auto " must be checked for " Maximum stitch space spacing " if you want to generate exactly the number of stitch plates that are entered here. Those stitch plates will be equally spaced.

Swap ends ( obj . SwapEnds or obj.swap_ends ): ( "Yes" ) or  ( "No" ). The choice you make here results in the entry of a string ( "Yes" or "No" ) to the parametric code.

If this box is checked ( ), the box is checked for " Swap member ends " on the Vertical Brace Edit window of the new, parametrically generated brace when this script is Run in Modeling . The parametric code reads: obj.SwapEnds = "Yes" (where obj is the " Object name ").

If the box is not checked ( ), the parametric vertical brace is generated without its ends being swapped.


------ Left end settings ------ | ------ Right end settings ------

Tip 1: The left end is the end that corresponds to this brace's " Left end point ." During Process and Create Solids , the left and right ends are switched if the " Left end point " is to the right of " Right end point. " Tip 2 : Additional attributes not on this window are available for left/right setbacks and left/right end reactions .

Input connection type ( obj . LeftEnd.InputConnectionType ) or ( obj . RightEnd.InputConnectionType ): "Vbrace plate" or "Plain end" . The choice you make here results in the entry of a string ( "Vbrace Plate" or "Plain end" ) to the parametric code.

"Vbrace plate" instructs connection design to create an appropriate system connection according to the vertical brace's framing situation. For the left end, the parametric code reads: obj.LeftEnd.InputConnectionType = "Vbrace Plate" (where obj is the " Object name ").

"Plain end" prevents connection design from creating a connection on this end. For the left end, the parametric code reads: obj.LeftEnd.InputConnectionType = "Plain end" .


To close this window :

   

"OK" (or the Enter key) closes this window and saves your changes to RAM.

"Cancel" (or the Esc key) closes this window without saving any changes that you have made to it.

"Reset" undoes all changes made to this window since you first opened it. The window remains open.