The Parametric Column Add window

Quick Notes

Also see :

Warning : If you are using imperial dimensioning, make entries to fields on this window in decimal inches, not fractions. Also, do not use hyphens (-). If you enter a fraction using integers, Python truncates the results of the division operation to an integer (examples: 1/8 = 0 ; 5/4 = 1 ). If you enter fractions with decimal points, Python calculates the precise decimal value (examples: 1.0/8.0 = .125 ; 5.0/4.0 = 1.25 ). If you enter a hyphen, Python interprets the hyphen as a minus sign (examples: 1-2 = -1 ; 3-2 = 1 ). See numbers (floating point numbers and integers). Also see Units("...") , which set whether you need to enter dimensions in decimal inches or millimeters.


------ General settings ------

Section size ( obj . SectionSize or obj.section_size ): " String " plus a string or " String " plus a variable . Connections can be designed for wide flange , welded plate wide flange , welded plate box , HSS round and HSS rectangular columns.

If the box for " String " is checked ( ), you can type in the section size that you want, or you can press the "file cabinet" browse button ( ) and double-click any section that is on the list of available materials in the local shape file . For example, if you were to enter W14x90 , the resulting line of parametric code reads: obj.SectionSize = "W14x90" (where obj = object ).

If the box for " String " is not checked ( ), you can assign this column the section size of a previously added material or member main material. For example, you could enter mem1.SectionSize to get the section size of a previously named member object called mem1. In the parametric code, the variable will not be in quotes, since the variable itself is not a string, though it returns a string.

Piecemark ( obj . Piecemark or obj.piecemark ): Blank or a user piecemark .

If you leave this blank : No line for assigning a piecemark is included in the code generated by this window. A system piecemark will be assigned to the parametrically added member during Process and Create Solids .

If you enter characters here : Be sure to put them in quotes ("..."). The resulting code is something like: obj.Piecemark = "my_pcmk" , and this member is assigned my_pcmk as its user piecemark at the time this script is Run . Warning : If you do this, it is your responsibility to ensure that you Run the script in a Job where there are no members that have already been assigned that piecemark. If you do not properly track user piecemarks, you may get members that are physically quite different but share the same user piecemark.

Tip: A Python script can read piecemarks (user or system) as shown in the following example:

# Prints the piecemark of the member that the user selects.
from member import MemberLocate
from param import ClearSelection
mem1 = MemberLocate("Select a member")
print("The piecemark is: ", mem1.Piecemark)
ClearSelection()

Steel grade ( obj . MaterialGrade or obj.grade ): Any steel grade ( "A36" or "A572" or etc.) from the list of " Wide Flange Grades " (for wide flange columns) or " Pipe Grades " (for HSS round columns) or " HSS/TS Grades " (for HSS rectangular columns).

Example: Selecting A36 results in a line of parametric code that reads: obj.MaterialGrade = "A36" (where obj is the " Object name " and "A36" is a string from one of the aforementioned setup tables).

Sequence ( obj . ErectionSequence or obj.sequence ): Any sequence name (a string ) from Home > Project Settings > Job > Zone and Sequence > press " Sequence Names " > Sequence Names .

Example: Entering 2 results in a line of parametric code that reads: obj.ErectionSequence = "2" (where obj is the " Object name ").

Erection pin hole ( obj . ColumnErectionPinHole or obj.erection_pin_hole ): "Automatic" or "Yes" or "No" . An erection pin hole is a lift hole near the top of a column that can be used by a crane to lift the column into place. The choice you make here results in the entry of a string ( "Automatic" or "Yes" or "No" ) to the parametric code.

"Automatic" applies the selection made to " Show erection pin holes on columns " in Home > Project Settings > Fabricator > Detailing > Member Detailing Settings > the " Columns " tab.

"Yes" instructs Process and Create Solids to place a pin hole centered at the half-depth of the column. The pin hole is the diameter and edge distance specified in Member Detailing Settings .

"No" instructs Process and Create Solids to not add a pin hole -- regardless of the choice made in Member Detailing Settings .

Column rotation ( obj . Rotation or obj.rotation ): A positive or negative (-) floating point number from 90.0 to -90.0 degrees. 0 degrees orients the column based on the slope of a column (see the examples below). A positive number rotates the column counterclockwise from the zero position that number of degrees. A negative (-) number rotates the column clockwise from the zero position.

0
45
-45
90
0 degrees sets the web of a perfectly vertical column parallel with the X axis in a plan view.

0 degrees
0 degrees
0 degrees
As shown in the left example, ' 0 ' degrees sets the web of a sloping column parallel to the X axis if the slope of the column is along the X axis in a plan view. The middle example shows a column whose slope is along the Y axis in a plan view.

Example: An entry of 90.0 results in a line of parametric code that reads: obj.Rotation = 90.0 (where obj is the " Object name ").

Long leg ( obj . LongLegOfAngleIsVertica or obj.LLV ): "Normal" or "Reversed" . This applies when angle material is entered as the " Section size ." The choice you make here results in the entry of a string ( "Normal" or "Reversed" ) to the parametric code.

"Normal"
"Reversed"

"Normal" orients the long leg of the angle to be horizontal in a plan view when 0 is the " Column rotation ." The parametric code reads: obj.LongLegOfAngleIsVertical = "Normal" (where obj is the " Object name ").

"Reversed" positions the long leg of the angle so that it is vertical in a plan view when 0 is the " Column rotation ." The parametric code reads: obj.LongLegOfAngleIsVertical = "Reversed" (where obj is the " Object name ").

Double material ( obj . DoubleMaterial or obj.is_double ): ( "Yes" ) or ( "No" ). This applies when angle or channel material has been entered as the " Section size ." SDS2 programs cannot design connections on columns made of these materials. The choice you make here results in the entry of a string ( "Yes" or "No" ) to the parametric code.

Double material
Double material

If this box is checked ( ), two angles (or two channels) are used as the column main material. The two angles may be oriented "Back to back" or in a "Star" " Configuration ." Two channels are always be back to back. The parametric code reads: obj.DoubleMaterial = "Yes" (where obj is the " Object name ").

If the box is not checked ( ), a single angle (or channel) is used as the column main material. The parametric code reads: obj.DoubleMaterial = "No" (where obj is the " Object name ").

Toe direction ( obj . ToeIO or obj.toeio ): "In" or "Out" . This applies only if channel or single angle material is entered as the " Section size ." The choice you make here results in the entry of a string ( "In" or "Out" ) to the parametric code.

"In"
"Out"

"In" (with the long leg "Normal" ) faces the toe of the angle or the flanges of the channel toward the near side of the column. In other words, "In" means that the toe or the flanges point down (or to the right if the " Column rotation " is 90.0 ). The parametric code reads: obj.ToeIO = "In" (where obj is the " Object name ").

"Out" (with the long leg "Normal" ) faces the toe of the angle or the flanges of the channel away from the near side of the column. A plan view looks at members from the bottom up (or right in for members whose webs are vertical in a plan view), "Out" means that the toe or the flanges points up (or to the left if the " Column rotation " is 90.0 ). The parametric code reads: obj.ToeIO = "Out" (where obj is the " Object name ").

Configuration ( obj . Configuration or obj.configuration ): "Star" or "Back to back" . This applies when an angle has been entered as the " Section size " and the box for " Double material " is checked. The choice you make here results in the entry of a string ( "Star" or "Back to back" ) to the parametric code.

"Star"
"Back to back"

"Star" lays out the two angles out so that the outside corner of each angle is along the work line of the column and no legs are back to back. The parametric code reads: obj.Configuration = "Star" (where obj is the " Object name ").

"Back to back" lays out the two angles so that one leg of each angle is back-to-back. The parametric code reads: obj.Configuration = "Back to back" .


------ Left end settings ------ | ------ Right end settings ------

Tip 1: The bottom end is the " Left end point " end of a column. Process and Create Solids switches the left and right ends if the " Left end point " is to the right (below on a vertical column) of the " Right end point. " Tip 2: Additional attributes not on this window are available for left/right setbacks and left/right end reactions .

Input connection type ( obj . LeftEnd.InputConnectionType ) or ( obj . RightEnd.InputConnectionType ): "Auto standard" or "Plain end" . The choice you make here results in the entry of a string ( "Auto standard" or "Plain end" ) to the parametric code.

Auto standard instructs Process and Create Solids to design an appropriate system connection based on the column's framing situation . Auto standard connections have a number of advantages . For the left end, the result is a line of parametric code that reads: obj.LeftEnd.InputConnectionType = "Auto standard" (where obj is the " Object name ").

Plain end prevents Process and Create Solids from designing a connection on this end. For the left end, the result is a line of parametric code that reads: obj.LeftEnd.InputConnectionType = "Plain end" .


To close this window :

   

"OK" (or the Enter key) closes this window and saves your changes to RAM.

"Cancel" (or the Esc key) closes this window without saving any changes that you have made to it.

"Reset" undoes all changes made to this window since you first opened it. The window remains open.