The Parametric Horizontal Brace Add window

Quick Notes

About this window :

Also see :

Warning :

  • If you are using imperial dimensioning, make entries to fields on this window in decimal inches, not fractions. Also, do not use hyphens (-). If you enter a fraction using integers, Python truncates the results of the division operation to an integer (examples: 1/8 = 0 ; 5/4 = 1 ). If you enter fractions with decimal points, Python calculates the precise decimal value (examples: 1.0/8.0 = .125 ; 5.0/4.0 = 1.25 ). If you enter a hyphen, Python interprets the hyphen as a minus sign (examples: 1-2 = -1 ; 3-2 = 1 ). See numbers (floating point numbers and integers). Also see Units("...") , which set whether you need to enter dimensions in decimal inches or millimeters.

------ General settings ------

Section size ( obj . SectionSize or obj.section_size ): " String " plus a string , or " String " plus a variable . Connection design can create connections for wide flange , welded plate wide flange , W tee , HSS round and HSS rectangular horizontal braces.

If the box for " String " is checked ( ), you can type in the section size that you want, or you can press the "file cabinet" browse button ( ) and double-click any section that is on the list of available materials in the local shape file . For example, if you were to enter L5x3x3/8 , the resulting line of parametric code reads: obj.SectionSize = "L5x3x3/8" (where obj is the " Object name "). Note from this example that you do not have to put the section size in quotes -- since this box is checked.

If the box for " String " is not checked ( ), you can assign this horizontal brace the section size of a previously added material or member main material. For example, you could enter mem1.SectionSize to get the section size of a previously named member object called mem1. In the parametric code, the variable will not be in quotes, since the variable itself is not a string, though it returns a string.

Piecemark ( obj . Piecemark or obj.piecemark ): Blank or a user piecemark .

If you leave this blank : No line for assigning a piecemark is included in the code generated by this window. SDS2 piecemarking assigns a system piecemark to the parametrically added member during Process and Create Solids .

If you enter characters here : Be sure to put them in quotes ("..."). The resulting code is something like: obj.Piecemark = "my_pcmk" , and this member is assigned my_pcmk as its user piecemark at the time this script is Run . Warning : If you do this, it is your responsibility to ensure that you Run the script in a Job where there are no members that have already been assigned that piecemark. If you do not properly track user piecemarks, you may get members that are physically quite different but share the same user piecemark.

Tip: A Python script can read piecemarks (user or system) as shown in the following example:

# Prints the piecemark of the member that the user selects.
from member import MemberLocate
from param import ClearSelection
mem1 = MemberLocate("Select a member")
print("The piecemark is: ", mem1.Piecemark)
ClearSelection()

Steel grade ( obj . MaterialGrade or obj.grade ): Any steel grade ( "A36" or "A572" or etc.) from the list of Angle Grades (for angle horizontal braces) or " Wide Flange Grades " (for wide flange horizontal braces) or " Pipe Grades " (for HSS round horizontal braces) or " HSS/TS Grades " (for HSS rectangular horizontal braces).

Example: Selecting A36 results in a line of parametric code that reads: obj.MaterialGrade = "A36" (where obj is the " Object name " and "A36" is a string from one of the aforementioned setup tables).

Sequence ( obj . ErectionSequence or obj.sequence ): Any sequence name (a string ) from Home > Project Settings > Job > Zone and Sequence > press " Sequence Names " > Sequence Names .

Example: Entering 2 results in a line of parametric code that reads obj.ErectionSequence = "2" (where obj is the " Object name ").

Long leg ( obj . LongLegOfAngleIsVertical or obj.LLV ): "Outstanding" or "To gusset" . This applies when the " Section size " is an angle with unequal legs. The choice you make here results in the entry of a string ( "Outstanding" or "To gusset" ) to the parametric code.

Outstanding
To gusset

"Outstanding" bolts the short leg of the angle to the gusset. For a non-sloping horizontal brace, this makes the long leg vertical. Parametric code: obj.LongLegOfAngleIsVertical = "Outstanding" (where obj is the " Object name ").

"To gusset" bolts the long leg of the angle to the gusset. For a non-sloping horizontal brace, this makes the long leg horizontal. Parametric code: obj.LongLegOfAngleIsVertical = "To gusset" (where obj is the " Object name ").

Long side ( obj . LongSide or obj.long_side ): Vertical ( "VT." ) or Horizontal ( "HZ." ) This applies when a tube material is the " Section size ." The choice you make here results in the entry of a string ( "VT." or "HZ." ) to the parametric code.

"VT."
"HZ."

"VT." specifies that the longer side of the tube brace be vertical. The parametric code reads: obj.LongSide = "VT." (where obj is the " Object name ").

"HZ." specifies that the longer side of the tube brace be horizontal. The parametric code reads: obj.LongSide = "HZ."

Double material ( obj . DoubleMaterial or obj.is_double ): ( "Yes" ) or ( "No" ). This applies when the " Section size " is an angle . The choice you make here results in the entry of a string ( "Yes" or "No" ) to the parametric code.

If this box is checked ( ), the horizontal brace is a double angle brace. The angles are back-to-back if either Near or Far is selected for " Side of gusset ." One angle is placed on the far side of the gusset and the other on the near side if Bolt sides is selected for " Side of gusset ." The parametric code reads: obj.DoubleMaterial = "Yes" (where obj is the " Object name ").

If the box is not checked ( ), the horizontal brace is a single angle. The parametric code reads: obj.DoubleMaterial = "No" (where obj is the " Object name ").

One gage line ( obj . OneGageLineOfBoltsOnBrace or obj.one_gage_line ): ( "Yes" ) or ( "No" ). This applies when the " Section size " is an angle . The choice you make here results in the entry of a string ( "Yes" or "No" ) to the parametric code.

One gage line
One gage line

If this box is checked ( ), connection design creates the angle-to-gusset interface with a single column of bolts. This may also cause the gusset plate to be designed larger or thicker. The parametric code reads: obj.OneGageLineOfBoltsOnBrace = "Yes" (where obj is the " Object name ").

If the box is not checked ( ), connection design creates the angle-to-gusset interface with two columns of bolts when the angle leg to the gusset is 5 inches (127 mm) or longer. The parametric code reads: obj.OneGageLineOfBoltsOnBrace = "No" (where obj is the " Object name ").

Stagger bolts ( obj . StaggerBoltsAtAngleBraceConnections or obj.stagger_bolts ): ( "Yes" ) or ( "No" ). This applies when an angle has been entered as the " Section size " and the leg to gusset is 5 inches (127 mm) or longer. The choice you make here results in the entry of a string ( "Yes" or "No" ) to the parametric code.

Stagger bolts
Stagger bolts

If this box is checked ( ), connection design creates a staggered bolt pattern. The parametric code reads: obj.StaggerBoltsAtAngleBraceConnections = "Yes" (where obj is the " Object name ").

If the box is not checked ( ), connection design does not stagger the two columns of bolts that fasten the angle to the gusset. The parametric code reads: obj.StaggerBoltsAtAngleBraceConnections = "No" (where obj is the " Object name ").

Side of gusset ( obj . SideOfGusset or obj.side_of_guss ): Far ( "FS" ) or Near ( "NS" ). This option selects the face of the gusset plate for attachment of an angle or tee or double angle horizontal brace. The choice you make here results in the entry of a string ( "FS" or "NS" ) to the parametric code.

"FS"
"NS"

"FS " bolts the brace to the far side of the gusset plate (its bottom face). The parametric code reads: obj.SideOfGusset = "FS" (where obj is the " Object name ").

"NS" bolts the horizontal brace to the near side face (the top face) of the gusset plate. The parametric code reads: obj.SideOfGusset = "NS" (where obj is the " Object name ").

Locate on neutral axis ( obj . PlaceAngleBracesOnNeutralAxisDescription or obj.neutral_axis ): "Automatic" or "Yes" or "No" .This applies when the " Section size " is an angle . Regardless of the selection made here, the member line of the horizontal brace runs along the surface of the angle leg that attaches to the gusset. In the parametric code, the choice made here is designated with a string ( "Automatic" or "Yes" or "No" ).

member line ( x )
on neutral axis
member line ( x )
on gage line

"Automatic" applies the choice made to " Locate angle braces on neutral axis " in Home > Project Settings > Fabricator > Detailing > Member Detailing Settings > the " Horizontal Braces " tab.

"Yes" causes the angle material's X-X axis or Y-Y axis (shown in the AISC Structural Shapes tables) to intersect with the member line of the brace.

"No" aligns the gage line of the angle material with the work line of the brace. An angle's gage line is the " Long leg gage " or " Short leg gage " entered in the local shape file .

Min gusset thickness ( obj . UserInputMinGussetThickness or obj.min_guss_thick ): Auto (blank) or the minimum thickness (a floating point number in the startup code " Units ") of the gusset plate.

If " Auto " is checked ( ), no line for the minimum gusset thickness appears in the code. " Minimum gusset thickness " on the Horizontal Brace Edit window of the parametrically added brace is automatically set to " Auto ," and connection design applies the " Minimum gusset plate thickness " in Standard Fabricator Connections (setup) when that parametrically added brace undergoes Process and Create Solids .

If " Auto " is not checked ( ), connection design creates a gusset plate that is as thick or thicker than the thickness that is entered here.

Warning : Click here before entering a distance.

Stitch plate gap ( obj . StitchPlateGap or obj.stitch_pl_gap ): Auto (blank) or the distance (a floating point number in the startup code " Units ") between " Double material " angle braces. This also sets the thickness of the stitch plate ( spacer ).

stitch plate gap = 0
stitch plate gap > 0

Auto results in no line for the stitch plate gap appearing in the code. " Stitch plate gap " on the Horizontal Brace Edit window of the parametrically added brace is automatically be set to " Auto, " and connection design generates a gap that is equal to the gusset plate thickness for a double-angle horizontal braces on Both sides of the gusset. For a double-angle horizontal brace on one side of the gusset, the gap is zero.

If the box for " Auto " is not checked ( ), then the distance that is entered here sets the gap that separates the two angles that make up the double-material brace.

Warning : Click here before entering a distance.

Swap ends ( obj . SwapEnds or obj.swap_ends ): ( "Yes" ) or  ( "No" ). The choice you make here results in the entry of a string ( "Yes" or "No" ) to the parametric code.

If this box is checked ( ), the box is checked for " Swap member ends " on the Horizontal Brace Edit window of the new brace that is generated when this script is Run in Modeling . The parametric code reads: obj.SwapEnds = "Yes" (where obj is the " Object name ").

If the box is not checked ( ), the parametric horizontal brace is generated without its ends being swapped.


------ Left end settings ------ | ------ Right end settings ------

Tip 1: The left end is the end that corresponds to this brace's " Left end point ." Process and Create Solids switches the left and right ends if the " Left end point " is to the right of " Right end point. " Tip 2 : Additional attributes not on this window are available for left/right setbacks and left/right end reactions .

Input connection type ( obj . LeftEnd.InputConnectionType ) or ( obj . RightEnd.InputConnectionType ): "Hbrace plate" or "Plain end" . The choice you make here results in the entry of a string ( "Hbrace plate" or "Plain end" ) to the parametric code.

"Hbrace plate" instructs connection design to create an appropriate system connection according to the horizontal brace's framing situation. For the left end, the result is a line of parametric code that reads: obj.LeftEnd.InputConnectionType = "Hbrace plate" (where obj is the " Object name ").

"Plain end" prevents connection design from designing a system connection on this end. For the left end, the parametric code reads: obj.LeftEnd.InputConnectionType = "Plain end" .


To close this window :

   

"OK" (or the Enter key) closes this window and saves your changes to RAM.

"Cancel" (or the Esc key) closes this window without saving any changes that you have made to it.

"Reset" undoes all changes made to this window since you first opened it. The window remains open.